ONJava.com -- The Independent Source for Enterprise Java
oreilly.comSafari Books Online.Conferences.

advertisement

AddThis Social Bookmark Button
Article:
  PHP 4.3 and Mac OS X
Subject:   Having problems with LDAP
Date:   2003-02-04 08:22:35
From:   qperkins
Since 10.2 was released, I have been able to use the built-in OpenLDAP libraries when I have built PHP 4.2x with just a --with-ldap flag.


I am trying to build 4.3 for the first time with the following config line:
./configure --with-apxs --with-ldap --with-zlib --with-gd --enable-ftp --with-jpeg-dir=/sw --with-tiff-dir=/sw --with-pdflib=/sw --with-png-dir=/sw --with-mysql --with-freetype-dir=/sw --enable-sockets --with-xml --enable-ftp


As you can see from my /sw directory, I am using Fink's libraries for the graphic pieces,but the problem is with LDAP. I am getting the following error:
checking for LDAP support... yes
configure: error: Cannot find ldap libraries in /usr/lib.


I am using a 4.2.3 build of PHP on the same server with LDAP with no problem. Anyone have any ideas?


Quinn Perkins



1 to 1 of 1
  1. Having problems with LDAP
    2003-02-24 14:58:35  qperkins [View]

    • Having problems with LDAP
      2003-02-28 20:37:42  tychay [View]

1 to 1 of 1