ONJava.com -- The Independent Source for Enterprise Java
oreilly.comSafari Books Online.Conferences.

advertisement

AddThis Social Bookmark Button
Article:
  Installing Oracle 9iR2 on Red Hat 9
Subject:   installer hangs on RH 2.4.20-20.8 upgraded to 2.4.20-20.9
Date:   2003-12-08 07:29:47
From:   anonymous2
hi Roko-


I am trying to install Oracle 9ir2 on a red hat 9 box. Wanted to see if I could seek your help on a dead end I am running up against.


I downloaded the iso images for 2.4.20-20.8 from RH website and upgraded kernel to 2.4.20-20.9.


I was following the Roko's instructions on O'Reilly and installed the folowing packages from the cds:
gcc-3.2.2-5
cpp-3.2.2-5
glibc-devel-2.3.2-11.9
binutils-2.13.90.0.18-9
compat-gcc-7.3-2.96.118.i386.rpm
compat-libgcj-7.3-2.96.118.i386.rpm
compat-libgcj-devel-7.3-2.96.118.i386.rpm
nss_db-compat-2.2-20.i386.rpm


Roko mentioned that I should install the following precompiled packages from Jason's website (got the i686 packages wherever possible):
glibc-2.3.2-27.9.oracle.i386.rpm
glibc-2.3.2-27.9.oracle.i686.rpm
glibc-common-2.3.2-27.9.oracle.i386.rpm
glibc-debug-2.3.2-27.9.oracle.i386.rpm
glibc-debuginfo-2.3.2-27.9.oracle.i386.rpm
glibc-debuginfo-2.3.2-27.9.oracle.i686.rpm
glibc-debuginfo-common-2.3.2-27.9.oracle.i386.rpm
glibc-devel-2.3.2-27.9.oracle.i386.rpm
glibc-profile-2.3.2-27.9.oracle.i386.rpm
glibc-utils-2.3.2-27.9.oracle.i386.rpm
nptl-devel-2.3.2-27.9.oracle.i686.rpm
nscd-2.3.2-27.9.oracle.i386.rpm


I was able to install most packages except:
glibc-2.3.2-27.9.oracle.i686.rpm
glibc-common-2.3.2-27.9.oracle.i386.rpm
glibc-utils-2.3.2-27.9.oracle.i386.rpm
glibc-debug-2.3.2-27.9.oracle.i386.rpm


glibc-utils-2.3.2-27.9.oracle.i386.rpm AND glibc-debug-2.3.2-27.9.oracle.i386.rpm ARE DEPENDENT ON glibc-2.3.2-27.9.oracle.i686.rpm DEPENDENT ON glibc-common-2.3.2-27.9.oracle.i386.rpm.


So far so good.


When I try to install glibc-common-2.3.2-27.9.oracle.i386.rpm it says glibc-common-2.3.2-11.9 required by glibc-2.3.2-11.9 (installed). So I am at a dead end as both those packages are installed.


So finally I tried the runinstaller w/o the 4 packages:
glibc-2.3.2-27.9.oracle.i686.rpm
glibc-common-2.3.2-27.9.oracle.i386.rpm
glibc-utils-2.3.2-27.9.oracle.i386.rpm
glibc-debug-2.3.2-27.9.oracle.i386.rpm



The installer ran but got stuck immmediately at 'Installing Java Runtime Environment' and did not proceed anymore. Would there be any suggestions you might be able to offer on how I need to proceed or do differently.


Would it help to try and install this on the Fedora disto. Would it be essentially similar procedures?


Really your help in pointing me in the right direction. Not a hard core user of Linux yet. Trying to get there.


Thanks a lot and really appreciate your help.


monosij


1 to 6 of 6
  1. installer hangs on RH 2.4.20-20.8 upgraded to 2.4.20-20.9
    2004-07-20 12:59:35  infxdba [View]

  2. installer hangs on RH 2.4.20-20.8 upgraded to 2.4.20-20.9
    2004-07-20 07:18:26  infxdba [View]

  3. installer hangs on RH 2.4.20-20.8 upgraded to 2.4.20-20.9
    2004-07-20 00:38:49  infxdba [View]

  4. installer hangs on RH 2.4.20-20.8 upgraded to 2.4.20-20.9
    2004-05-06 07:07:12  matheus [View]

  5. installer hangs on RH 2.4.20-20.8 upgraded to 2.4.20-20.9
    2003-12-22 15:52:08  anonymous2 [View]

  6. installer hangs on RH 2.4.20-20.8 upgraded to 2.4.20-20.9
    2003-12-10 23:40:16  anonymous2 [View]

1 to 6 of 6