ONJava.com -- The Independent Source for Enterprise Java
oreilly.comSafari Books Online.Conferences.

advertisement

AddThis Social Bookmark Button
Article:
  Apache Web-Serving with Mac OS X: Part 2
Subject:   Error Message : test-cgi not found
Date:   2004-11-09 23:49:08
From:   ZeeshanMaqbool
I have read your tutorial and found it very useful .. but I am stuck with a simple problem.


1) If I look into finder under this path "/Library/WebServer/CGI-Executables" I dont see ne files (as u mentioned that there will be printenv and test-cgi)


2) I followed the tutorial till Part-1 done, Part-2 Page1 (but the test-cgi doesnt ececute) and access_log says :


127.0.0.1 - - [09/Nov/2004:22:46:05 -0800] "GET /cgi-bin/ HTTP/1.1" 403 284
127.0.0.1 - - [09/Nov/2004:22:49:52 -0800] "GET /cgi-bin/ HTTP/1.1" 403 284
127.0.0.1 - - [09/Nov/2004:22:50:25 -0800] "GET /cgi-bin/ HTTP/1.1" 403 284
127.0.0.1 - - [09/Nov/2004:22:59:29 -0800] "GET /cgi-bin/test-ccgi HTTP/1.1" 404 289
127.0.0.1 - - [09/Nov/2004:22:59:34 -0800] "GET /cgi-bin/test-cgi HTTP/1.1" 500 604
127.0.0.1 - - [09/Nov/2004:23:26:59 -0800] "GET /cgi-bin/test-cgi HTTP/1.1" 404 288
127.0.0.1 - - [09/Nov/2004:23:30:16 -0800] "GET /cgi-bin/test-cgi.cgi HTTP/1.1" 404 292



and error_logs says :


[Tue Nov 9 22:46:05 2004] [error] [client 127.0.0.1] attempt to invoke directory as script: /Library/WebServer/CGI-Executables
[Tue Nov 9 22:49:52 2004] [error] [client 127.0.0.1] attempt to invoke directory as script: /Library/WebServer/CGI-Executables
[Tue Nov 9 22:50:24 2004] [error] [client 127.0.0.1] attempt to invoke directory as script: /Library/WebServer/CGI-Executables
[Tue Nov 9 22:59:29 2004] [error] [client 127.0.0.1] script not found or unable to stat: /Library/WebServer/CGI-Executables/test-ccgi
[Tue Nov 9 22:59:34 2004] [error] (2)No such file or directory: exec of /Library/WebServer/CGI-Executables/test-cgi failed
[Tue Nov 9 22:59:34 2004] [error] [client 127.0.0.1] Premature end of script headers: /Library/WebServer/CGI-Executables/test-cgi
[Tue Nov 9 23:26:59 2004] [error] [client 127.0.0.1] script not found or unable to stat: /Library/WebServer/CGI-Executables/test-cgi
[Tue Nov 9 23:30:16 2004] [error] [client 127.0.0.1] script not found or unable to stat: /Library/WebServer/CGI-Executables/test-cgi.cgi


By looking at them could u plz tell me whats the prob with this CGI ..


(one more thing could someone place a copy of 'test-cgi' and 'printenv' on internet???)


Zeeshan


1 to 1 of 1
  1. Error Message : test-cgi not found
    2004-11-24 20:19:41  idenrosenthal [View]

1 to 1 of 1