advertisement

Article:
  An Introduction to WebObjects
Subject:   Direct to Web java.lang.ClassNotFoundException: Application error
Date:   2004-12-30 12:42:33
From:   Florijan
I am using OSX 10.3.7 with WebObjects 5.2.3


When i try making a Direct to Web project in XCode, and I go through the tutorial for it, i get a succesful compilation result, but when the projects starts running i don't get further from the command line. It loads it's WebObjects extensions, and then reposrts the following:


Can't load Application class, exiting...
java.lang.ClassNotFoundException: Application
at java.net.URLClassLoader$1.run(URLClassLoader.java:199)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
at com.webobjects._bootstrap.WOBootstrap.main(WOBootstrap.java:68)


Executable “D2WTutorial9” has exited with status 1.


i tried running it on a newly installed system, and on a newly made user, i can never get it to work. The funny thing is that the guy next to me can run those same tutorials, and also the project that i made and transferred to him.


Any help would be appreciated because i really don't know where this is coming from.


Thanks


1 to 1 of 1
  1. Josh Paul photo Direct to Web java.lang.ClassNotFoundException: Application error
    2004-12-30 14:17:43  Josh Paul | O'Reilly Author [View]

    • Direct to Web java.lang.ClassNotFoundException: Application error
      2004-12-31 05:43:22  Florijan [View]

      • problem fixed
        2004-12-31 06:13:25  Florijan [View]

        • problem fixed
          2006-12-09 23:32:02  dbsurf [View]

          • Josh Paul photo problem fixed
            2006-12-10 08:55:41  Josh Paul | O'Reilly Author [View]

            • problem fixed
              2006-12-11 08:36:58  dbsurf [View]

          • Josh Paul photo problem fixed
            2006-12-10 08:55:17  Josh Paul | O'Reilly Author [View]

        • problem fixed
          2005-05-17 08:01:11  janiceC [View]

          • problem fixed
            2005-05-17 08:14:16  janiceC [View]

1 to 1 of 1