ONJava.com -- The Independent Source for Enterprise Java
oreilly.comSafari Books Online.Conferences.

advertisement

AddThis Social Bookmark Button
Article:
  Rolling with Ruby on Rails
Subject:   difficulty installing
Date:   2005-01-26 10:41:07
From:   Challman
I'm behind a corporate firewall and proxy (with authentication). I can't get the "gem install rails --remote" to establish a connection. I've tried pointing local but it keeps looking to the 'net. I downloaded and ran install.rb for actionmailer, actionpack, activerecord and rake. I then tried "gem install rails" but it failed again. I then did a --force and it appeared to install:


C:\rails>gem install rails.gem --force
Attempting local installation of 'rails.gem'
Successfully installed rails, version 0.9.5
Installing RDoc documentation for rails-0.9.5...
WARNING: Generating RDoc on .gem that may not have RDoc.


lib/rails_generator.rb:34:46: Skipping require of dynamic string: "#{path}/#{nam
e}_generator.rb"



However, I can't execute "rails cookbook". Here is what I get:



C:\rails>rails cookbook
c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:131:in `activate': (Gem::LoadError)
Could not find RubyGem rake (>= 0.4.15)
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:150:in `activate'
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:149:in `each'
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:149:in `activate'
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:34:in `require_gem'
from c:/ruby/bin/rails:18


I've googled and searched and read but I still can't find something that helps. Any ideas?


1 to 3 of 3
  1. difficulty installing
    2005-02-02 02:49:27  Chilli [View]

  2. difficulty installing
    2005-01-26 11:02:01  Challman [View]

  3. Curt Hibbs photo difficulty installing
    2005-01-26 10:57:36  Curt Hibbs | O'Reilly AuthorO'Reilly Blogger [View]

    • difficulty installing
      2005-11-14 09:38:02  elaveriao [View]

      • difficulty installing
        2005-12-09 06:13:57  Plog [View]

1 to 3 of 3