ONJava.com -- The Independent Source for Enterprise Java
oreilly.comSafari Books Online.Conferences.

advertisement

AddThis Social Bookmark Button
Subject:   I totally agree with you
Date:   2006-01-07 19:26:34
From:   venge
Response to: I totally disagree with you

Every single point you mention about Ant are the very reasons I stated when we moved our projects to Maven 1.


I'm currently implementing one project with M2 but finding the dependancy gathering to be a little awkward. For example, I want to use Spring 1.2.6 and Hibernate 3.1 and I state that in my pom.xml. However, it will grab Hibernate 3.0.5 and Hibernate 2.1.7 as those are stated as requirements for Spring and doesn't "realise" that I'm already grabbing Hibernate.