ONJava.com -- The Independent Source for Enterprise Java
oreilly.comSafari Books Online.Conferences.

advertisement

AddThis Social Bookmark Button
Article:
  Rolling with Ruby on Rails
Subject:   What
Date:   2007-01-31 10:45:19
From:   thegrayman
Alright I get to the point where you have to change. I need a password as MySql wouldn't install without it for me. After changing the database.yml, I am getting this when starting the server:



C:\rails\cookbook>ruby script\server
./script/../config/boot.rb:29:Warning: require_gem is obsolete. Use gem instead
.
=> Booting WEBrick...
c:/ruby/lib/ruby/1.8/yaml.rb:133:in `load': syntax error on line 1, col 9: `
adapter: mysql' (ArgumentError)
from c:/ruby/lib/ruby/1.8/yaml.rb:133:in `load'
from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/initializer.rb:523:i
n `database_configuration'
from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/initializer.rb:228:i
n `initialize_database'
from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/initializer.rb:88:in
`process'
from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/initializer.rb:43:in
`send'
from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/initializer.rb:43:in
`run'
from ./script/../config/../config/environment.rb:13
from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `ge
m_original_require'
... 13 levels...
from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_suppo
rt/dependencies.rb:496:in `require'
from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_suppo
rt/dependencies.rb:343:in `new_constants_in'
from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_suppo
rt/dependencies.rb:496:in `require'
from script/server:3


C:\rails\cookbook>


1 to 2 of 2
  1. What
    2007-02-10 17:41:33  donkaiser [View]

  2. Curt Hibbs photo What
    2007-01-31 10:55:26  Curt Hibbs | O'Reilly AuthorO'Reilly Blogger [View]

1 to 2 of 2