ONJava.com -- The Independent Source for Enterprise Java
oreilly.comSafari Books Online.Conferences.

advertisement

AddThis Social Bookmark Button
Article:
  Rolling with Ruby on Rails
Subject:   Installation Problem
Date:   2007-02-24 01:12:32
From:   kudi
After downloading ruby182-14.exe from One-Click Ruby Installer for Windows and installing it, i ran the command gem install rails --remote in command prompt.
The output was


C:\>gem install rails --remote


C:\>"c:\ruby\bin\ruby.exe" "c:\ruby\bin\gem" install rails --remote
Attempting remote installation of 'rails'
Updating Gem source index for: http://gems.rubyforge.org
Install required dependency activerecord? [Yn] y
Install required dependency activesupport? [Yn] y
Successfully installed odbc-rails, version 1.3
Installing RDoc documentation for odbc-rails-1.3...


lib/active_record/connection_adapters/odbc_adapter.rb:425:37: Skipping require o
f dynamic string: "#{@odbcExtFile}"


lib/active_record/connection_adapters/odbc_adapter.rb:1616:30: Skipping require
of dynamic string: "#{dbExt}"
Installing RDoc documentation for activerecord-1.15.2...
Installing RDoc documentation for activesupport-1.4.1...


After that when i wrote rails cookbook, i got an error stating "rails cannot be identified as internal or external command"


C:\>cd rails


C:\rails>rails cookbook
'rails' is not recognized as an internal or external command,
operable program or batch file.


I am learning Ruby for first time and tried to install but got this error.


Please help.