New Camera Support for Tiger Users

by Ben Long

With the release of Leopard, Apple added raw support for a number of new cameras, leaving Tiger-based Aperture users wondering if they would be forced to upgrade to the new operating system in order to gain support for the new formats.

Fortunately, the answer to that question is a resounding "no!" thanks to Apple's 10.4.11 update, now available via Software Update. In addition to a number of OS level bug fixes, the update provides support for the following cameras: Panasonic Lumix DMC-FZ50, Leica V-Lux 1, Olympus E-400, Olympus EVOLT E410, Olympus EVOLT E510, and the Canon EOS 40D.

As an Aperture user, is there any reason at this point that you should be hesitant to upgrade to Leopard? Not really, though if you rely a lot on external Firewire drives, you might want to test them with a Leopard system before making the switch. I've found that some of my drives aren't showing up in Leopard - something that happens from time to time with Apple updates. Usually, an OS update soon follows to fix the problem.